Laravel Passport Install Class Not Found

Posted by

Error

 Problem 1
    - laravel/passport[v4.0.0, ..., v4.0.3] require guzzlehttp/guzzle ~6.0 -> found guzzlehttp/guzzle[6.0.0, ..., 6.5.8] but it conflicts with 
your root composer.json require (^7.2).
    - Root composer.json requires laravel/passport 4.0.* -> satisfiable by laravel/passport[v4.0.0, v4.0.1, v4.0.2, v4.0.3].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.

Solution:

Step 1: Delete composer.lock file

Step 2: Run this command composer require laravel/passport –with-all-dependencies

Step 3: Add version passport  “laravel/passport”: “11.9.0”,

After that run composer update

Thanks my error is solved

Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x